Trouble filling gas tank
Hazcon

Arlington, TX

#287 Sep 21, 2011
Problem is same as above. Vehicle is 2004 Dodge Caravan.
Why is there no answer to this issue?
Ann

Woodbury, NJ

#288 Sep 25, 2011
07 Escape and I have the same problem. Brought it into dealer a year ago. Now, it is doing the same thing again. Called for an appointment and was told it was in my file that it was "spiders nesting" and that is what is blocking the fuel entrance. Do not believe they mentioned that last year. Too weird not to remember. But there was also a part they replaced. I believe they discounted my repair.
Anyway, have an appointment this week. I saw on a site that Mazda recalled one of its models for this issue. Wonder what Ford will do. Going to call corporate this week.
LC Quin

Arlington, VA

#289 Sep 26, 2011
Hundai Elantra 2001- Slow Fuel Fill Problem - it only takes $1.oo of gas at a time. File your complaint with NTSA to begin an investigation and recall.
mcthumber

Winchendon, MA

#290 Sep 27, 2011
Hazcon wrote:
Problem is same as above. Vehicle is 2004 Dodge Caravan.
Why is there no answer to this issue?
I don't know the answer but from everything I've read, the problem often starts with overfilling the tank. Gas gets into areas it shouldn't (charcoal canisters, vent tubes, etc) and causes the problem. I have a hard time believing it is due to insect infestations (even though I saw the youtube wasp video). Overfilling seems to make more sense.

So prevention is the key-- when the automatic gas shutoff snaps off, remove the nozzle. DON'T try to squeeze in more gas to round up to the next dollar or "top off" the tank. This is one reason I always pump my own gas (sorry NJ residents). I don't trust any pimply-faced high school kid pumping for me anymore.
jerome

Indianapolis, IN

#291 Sep 29, 2011
do any body know how to fixes this.
Cheryl

Wethersfield, CT

#292 Sep 30, 2011
I also have a 2005 Ford Escape. Love it. But, for the past couple of months, and only on occasion, I have a tough time filling the fuel tank. I keep getting a 'backwash' of fuel when trying to fill up. I've checked the obvious (need for fuel, correct as gauge reading, even tried different pumps at different locations), and, nothing works. I see a lot of folks have this same problems, with a variety of vehicles: Does anyone have a remedy? I've got around 84000 mi. on it...good fuel mileage, service is up to date.
Cheryl

Wethersfield, CT

#293 Sep 30, 2011
mcthumber wrote:
<quoted text>I don't know the answer but from everything I've read, the problem often starts with overfilling the tank. Gas gets into areas it shouldn't (charcoal canisters, vent tubes, etc) and causes the problem. I have a hard time believing it is due to insect infestations (even though I saw the youtube wasp video). Overfilling seems to make more sense.
So prevention is the key-- when the automatic gas shutoff snaps off, remove the nozzle. DON'T try to squeeze in more gas to round up to the next dollar or "top off" the tank. This is one reason I always pump my own gas (sorry NJ residents). I don't trust any pimply-faced high school kid pumping for me anymore.
Thanks! That may be the issue; I'm always trying to get that 'extra drop' in. Does anyone in this forum do the same thing? It'd be interesting to figure this out! I'll keep the 'topping off' habit down!
Ignacio

Harlingen, TX

#294 Oct 1, 2011
i had the same problem with my '00 gmc sierra after replacing the fuel pump. check underneath while filling up tank, mine had a leak from the filler hose so it would make the pump stop. the has has 2 clamps one where you put fuel hose and one that connects to the tank itself.
anthony

Greenville, TX

#295 Oct 6, 2011
I have a 2003 Hyundai elantra. And my gas stop bout every five seconds it takes about 20 mins to fill up which sucks Idk Wat to do..
emt

Canton, OH

#296 Oct 6, 2011
I think you have a bad vent solinoid in the evap system it is around the spare tire or by the gas tank has your check engine light been on if so have it checked out at autozone for free hope this helps.
Bill L wrote:
I have a 2006 Aveo. I drive 148 per day round trip.
I have 29,000 miles on the car. The last few months on five different occasions I could not get gas to go in the tank. I brought the car in and they said there were spider webs in the breather line. Which I think is very odd. Antway they were able to put gas in it after they poked out the cobwebs with a wire. Off I went happy. Well I tried to fill up this morning with a 1/4 tank of gas, I could only get $1.27 in the tank. Ican only fill the tube going to the tank. The gas spills out and seeps in extremely slow. Has anyone out there experienced this. I know this sounds crazy. Please help.
Devin

Carthage, IN

#297 Oct 25, 2011
My 2000 impala has the same shut goin on...it's gettin old...I'm tired of it not workin
Brian

Austin, TX

#298 Oct 28, 2011
2002 Sable LS having the same problem pumping gas and i also have the check engine light on and its telling me code P0442 the next thing to replace is the purge valve on the firewall under the hood i think its called. anyone else ever solve this problem
my car has 43k on it i am getting fed up
Jeanne

Saint Paul, MN

#299 Nov 2, 2011
Same problem on 2005 Suburu Legacy. Hard to believe that so many different cars have the same problem. Suburu dealer did diagnostic on mine and says that I need a new canister vent valve. Estimated cost is $400 -$600. But no guarantee that it will actually fix the problem. Any other recommendations?
BATTLEGROUNS

United States

#300 Nov 3, 2011
I have the same problem. I own a 2004 chevy silverado 3/4 ton HD. The guy working on my truck believes the problem to be the cylinoyd air vent. This piece is over $100.00.dose anyone know if this could possibly be the problem?
Troy

Canada

#301 Nov 5, 2011
clive wrote:
I have a 2005 chevy silverado 4.3 with 153,000 miles and have had this filling problem for a month now, when it warms up a little i'm going to try removing the vent line to the tank and see if I still have the same problem.
. Did u manage to get it fixed? I have same trouble
Cameron

San Bernardino, CA

#302 Nov 7, 2011
The same fill up problems started reciently in my 06 Jeep. at first it was only the Costco pumps then mobile, now where ever I fill up. Is it my Car? or are the changing the pump nozzles, or are they changing the makeup of the gasoline itself? Adding air or something to make the gasoline foam up so to read more gas sold than is really being pumped????
Brian

Austin, TX

#303 Nov 9, 2011
Troy wrote:
<quoted text>. Did u manage to get it fixed? I have same trouble
I had my vent valve replaced and it still does it. It doesnt seem as bad as before the pump only kicked off twice last time i filled up.
ryan23416

Waterloo, Canada

#305 Nov 14, 2011
Minx wrote:
Thanks Christi,
I'll go to nissan soon, so I figure around CDN$350 before taxes :(
I have a 03 senta and have the same problem manix please let me know how much cdn$ it costs you and if you went to nissan or somewhere else...
ryan23416

Mississauga, Canada

#306 Nov 15, 2011
I took out the hose leading to the tank and it was clear... I fished the filler nozzle with a wire and it was clear havn't checked the vent tube but seems like it's that or the canister...
Jeff

Landenberg, PA

#307 Nov 17, 2011
Bill L wrote:
I have a 2006 Aveo. I drive 148 per day round trip.
I have 29,000 miles on the car. The last few months on five different occasions I could not get gas to go in the tank. I brought the car in and they said there were spider webs in the breather line. Which I think is very odd. Antway they were able to put gas in it after they poked out the cobwebs with a wire. Off I went happy. Well I tried to fill up this morning with a 1/4 tank of gas, I could only get $1.27 in the tank. Ican only fill the tube going to the tank. The gas spills out and seeps in extremely slow. Has anyone out there experienced this. I know this sounds crazy. Please help.
I know it's probably too late for this. At the end of your filler line at the tank there is a spring loaded valve. This has a weak spring that allows the gravity of the gas flow to open it and it closes after you stop pumping gas in. This valve is sticking in the closed position. Most likely it has to do with the added Ethanol added to the gas(just s guess). But the sticking valve is the problem. It has to be replaced.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Aveo* Discussions

Title Updated Last By Comments
Aveo Exterior Door Lock Question. Please Help! (Sep '08) Jun 24 Bscott 83
Coolant loss Jun 21 Wimsey 8
News Chevy Trax crossover eclipses Sonic subcompact car Jun 19 Wimsey 1
2008 Chevrolet Aveo Lt won't start (Jul '13) Jun 8 Hellmarked 18
2004 aveo radio help (May '10) Jun 7 truck512 24
2005 Chevy Aveo HOLD light and steering wheel s... (Feb '11) Jun 3 Linda 31
2010 chevy Aveo fan not coming on Jun 1 katherine 3
More from around the web