2003 chevy avalanche
Randy

Huntsville, AL

#1 Jan 28, 2010
2003 chevy avalanche loss of power signal comes on and the traction control light and engine light comes on and engine has very little power. if you leave setting for a hour or so it cranks fine and runs fine but if you stop and come back and crank it the same problem has anyone had this problem
Crazy piney

United States

#2 Mar 28, 2010
Randy wrote:
2003 chevy avalanche loss of power signal comes on and the traction control light and engine light comes on and engine has very little power. if you leave setting for a hour or so it cranks fine and runs fine but if you stop and come back and crank it the same problem has anyone had this problem
Have you wheeled this?
Check where the ground wires go into the frame off the battery. There are also ones under the drivers door on the frame rail. There are 2 there. Check for corrosion and loose bolts. Stupid obvious stuff like that.
tomas

Glendale, CA

#3 Nov 17, 2011
mi truck start but wen i chango to drive the motor stop
gunnernavy

Kissimmee, FL

#4 Jul 19, 2012
While driving home, my 1500 4WD Avalanche stopped running. When I went to step on the gas it would not get any power. The engine was still running but it was acting like it was running out of gas. No engine check light is on or came on. Engine turns over like it wants to start..... Help...

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Avalanche Discussions

Title Updated Last By Comments
Avalanche SnugTop XUV shell for sale (Jul '13) 11 hr Jlf 27
Cheap Fitted Kitchens Sheffield Jul 23 qantengolo 1
fading body molding on avalanche (Feb '07) Jul 23 STEVE 47
News GM Expands Recall to Fix Truck, SUV Brakes (Mar '06) Jul 5 Jolene 74
Dead Batteries in 2007 Avalanche (Nov '06) Jun '16 ARTIE 22
Starting Problem... (Sep '10) May '16 rich3388 38
AirBag Warning light and DIC (Oct '06) Apr '16 dashecky 252
More from around the web