First Prev
of 2
Next Last
Q-tip

Charleston, SC

#21 Nov 20, 2008
i have a 93 Cadillac STS and i am proud of the power(which is 295 hp and 290 ft lbs torque) and handling of the car... the northstar engine even though expensive to fix most miner problems can be token care of by myself... with the small bit of mechanical skills i have...
all and all its a good car that i am going to try to keep on the road for a while... Ford man or not...

Since: May 09

Kitchener, Canada

#22 May 26, 2009
i have a 93 sts for sale or trade
Dan Z

Andover, NJ

#23 Jan 27, 2010
Missy wrote:
Does anyone know what service ride control m
eans. Just got a 93 sts northstar
I have the same question, The message came on about a week ago.

Dan Z
mike

Owings Mills, MD

#24 Oct 5, 2010
map sensor is under the plastic cover top center of the engine almost
vallieval

Hillsdale, MI

#25 Nov 8, 2011
I have a 95 sts and have had this problem for 3 years now. car runs fine other than an electrical issue. The dash lights wrk when they want to. Which also means when they dont work, i have no heat, have no idea how fast im going, have no idea how much gas i have, or anything like that. When they work everything works again? Its very spotty now when it even works. The gas and speed issue i can handle but the no heat with winter approaching and driving an hour to work im afraid i might lose toes! I called everywhere adn the only place willing to look is the dealership quoting me $3000.00???? Thats ridiculous! email me with any answers!! vallieval@gmail.com
Dan

Omaha, NE

#26 Apr 22, 2012
Brandon wrote:
I have a 93 sts and it was running fine than out of now were it just stoped running i have spark and new gas but it doesn't seem to be fireing at the same time so... here we go I put a new intake air temp, mass air flow, two crank sensors, cam sensor, Ignition Mod, spark plugs, fuel pressure regulator, computer (ECM,ECU,PCM) can not find MAP sensor assuming no sensor for this car what else should I do? I see mike had problem with security but it won't start at all. Please Help....
the MAP sensor it located on the right side of the fuel injector rail
Brad

Los Angeles, CA

#27 Jul 20, 2014
My1993 STS just stops running then will restart. It only has 56k miles on it. Any suggestions as to why it does this?

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 2
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Cadillac STS Discussions

Title Updated Last By Comments
02 sts May '14 bob 1
1975 Cadillac Seville: Not-Quite Classics (Jun '11) Feb '14 Benjamin Edge 11
Third brake light replacement (Sep '13) Dec '13 Martin M 2
2006 sts tire size (Apr '11) Sep '13 Rob 2
Chilton Repair Manual for 1990 - 1998 Cadillac STS (Apr '08) Jan '13 Roc 9
Problems & Solutions (Jan '06) Sep '12 mycaddy02 354
STS shuts off while driving at low speed or coa... (Aug '09) Jul '12 Arturo 6

Cadillac STS People Search

Addresses and phone numbers for FREE