bad sensor or something
derrick

Stevensville, MI

#1 Jul 11, 2006
I have 1994 a cadillac sts and it will run fine on crack up and everything for about 6 minutes or so, then the computer screen tells me to turn the car off because the coolant is hot. The fan is contantly coming on and off prematurly stays on for about3 seconds ang goes off and repeats. I took the car to cadillac and they said they didn't know what was wrong with it even after I put it on the machine. They wanted to break the motor down and completely overhaul the engine. I know the motor isnt hot that fast just by having common sense and you can touch the motor and it's still cold. Has anyone had this problem with their car?
mike

Sherbrooke, Canada

#2 Sep 20, 2006
I have the same problem have you found what it is yet? please let me know thanks playerette_11@hotmail.com

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Cadillac STS Discussions

Title Updated Last By Comments
Key fob Jan '17 Brianalex 1
News Problems & Solutions (Jan '06) Dec '16 Dbll 359
Transmission shift solenoid Nov '16 Heath 1
Chilton Repair Manual for 1990 - 1998 Cadillac STS (Apr '08) Nov '16 Heath 10
2008 sts wont shut off (Jul '16) Jul '16 jdzzl816b 1
2006 sts clicking upon accelaration (Jan '16) Jan '16 Joe g 1
code c1282 traction control,abs 2002 sts (Dec '06) Jan '16 B-EZY30 17
More from around the web