Buick Park Avenue

Buick Park Avenue

There are 449 comments on the Edmunds.com story from Mar 15, 2006, titled Buick Park Avenue. In it, Edmunds.com reports that:

Created by sysop in the Buick Sedans Message Board. Your Host is pat What is this discussion about? Buick Park Avenue, Sedan, Auto News, Opinion, Car Photos, Car Reviews # 305 of 314 Re: Fuel gauge fix ...

Join the discussion below, or Read more at Edmunds.com.

Hung Vu

Saint George, UT

#26 Sep 18, 2006
Bill wrote:
Dawn,
I am having the identical problem with my 95 Buick Park Avenue and I could have written your e-mail with the exception that my car has to be in park to restart it. It's like someone pulls the plug. The electrical system shuts down so I have no warning lights, turns signals, etc. Lately I have noticed that it takes about two times to start it when it hasn't been running whereas before it always started on the first try. It always starts back up after dieing and dies once or twice a day at this point.. except when I take it to the shop and then it doesn't act up! Can anyone help us?
<quoted text>
Dawn,
I have a 97 Buick Park Ave and I have exactly the same problem. I'll die sometime when costing down
Perspective

United States

#27 Sep 23, 2006
Dawn, have you had anyone check the fuel filter and fuel pump?
ray

Farmington, CT

#29 Oct 17, 2006
gorje wrote:
help i have a 1998 park ave,my check engine light turn on.I check it out at auto zone,and i was told it was an oxigen sensor,we replace that and it work well for a few months but, now is doing it again. my car turns off when Im driving,mostly at low speeds or if Im coasting.Anyone has any idea what I can do about it.we will be greatly appreciative.please e mail [email protected]
the problem is the map air flow sensor
Gary Beuker

Virginia Beach, VA

#30 Oct 20, 2006
I purchased A '98 Buick Park Avenue in Florida. Upon return to Virginia Beach, VA I noticed that the auto heater only covers cold air. How can I turn the heat on?
Arnie

Thompson, Canada

#31 Nov 4, 2006
1990 buick park avenue with 3800 motor - had fuel injectors flushed and now the level of oil seems to rise (garage seems to think there is gas going into it). changed spark plugs, new oxygen sensor, flushed injectors again, pressure test on injectors indicted no problem but oil is still rising (as opposed to using oil)

ANY SUGGESTIONS
RIFFY

United States

#32 Nov 7, 2006
I HAVE A 95 BUICK PARK AVE ULTRA IM HAVING A PROBLEM WITH THE VOLTAGE AND THE CAR KEEPING A CHARGE please help
Nelson

AOL

#33 Nov 7, 2006
My 96 Park Avenue "Coolant Low" indicator came on a moth or so ago. I checked the coolant and it was fine. Also, no overheatng problem at all. Normal. Now the heater suddenly stopped putting out warm air even though the fan blows like always. Anyone else ever experience this?
Nelson

AOL

#34 Nov 7, 2006
RIFFY wrote:
I HAVE A 95 BUICK PARK AVE ULTRA IM HAVING A PROBLEM WITH THE VOLTAGE AND THE CAR KEEPING A CHARGE please help
Go get a new battery, Riffy. Or just try another one for a couple of days. I had the same problem and after much service time it was discovered that the battery intermittently shorted a cell out due to vibration.
Donald

United States

#35 Nov 8, 2006
i have a 94 buick park ave and it won't stay running it only runs for five second then the shuts off it won't let it seat for awhile an over again i change the pump mod.
same ol crap

Saint Charles, IL

#36 Nov 8, 2006
yeah I have an 87' lesabre with similar problems it dies all the time and when it runs it runs great then just decides to shut off sometimes it fires right up other times it takes awhile i just towed it to the shop yesterday and apperently it has a broken timing chain and posible bent valves... anyone want to buy a real decent 87 lesabre that needs some work? [email protected] I might just replace the engine it might be cheaper
rick in mass

AOL

#37 Nov 10, 2006
hi my son has a 92 buick park ave and the engine light goes on and we have no power to start from a standstill. the computer said it was the module and coil, we replaced it and the same problem. it also said the knock sensor was bad...replacing that. the wierd part is when it heats up the light goes off and runs great, if you put on the heat or air and the engine temp drops the light goes back on and you lose start off power again.,,,thanks for any info
Judy

United States

#38 Nov 11, 2006
Hi, I have a 94 Buick Park Ave. & my horn didn't work so my mechanic replaced the fuse. Well, in the last twelve hours, it has started "blowing" on it's own while parked in the driveway. I think there might be some sort of a connection between the alarm system & the horn, because the remote would not open the door while the horn was going off. Help me please as I drive 80 miles round trip to school 5 days a week.
Dawn

Minot, ND

#39 Nov 11, 2006
Perspective wrote:
Dawn, have you had anyone check the fuel filter and fuel pump?
I had the fuel filter, fuel pump, ignition switch and even the computer was replaced couldn't get it fixed so I traded it off for a Mazda Tribute hopefully this works better. And the car did start dying on the dealership and the guy who bought it from the auction.
yes I was honest and told them what was wrong before they bought it from me and they think they can fix it good luck to them. Hey thanks for replying.
Have a great day
bob

United States

#40 Nov 12, 2006
Hey Dawn I had a 1994 buick skylark quit while going down the road, it would seem to spit and sputter than just shut off..even though it started right back up. this is what worked for me, try fuel injector cleaner you can get it at almost any store. and the computer is bad in that to but it still runs properly just with the use of some injector cleaner every now and then.
I hope this helps
bob

United States

#41 Nov 12, 2006
o yeah i forgot to mension only try that with most of a tank of gas and try to drive at least 30mins and ur car should be at least a little better. if that is true try it again just to make sure the injectors are clean. then do it once every 2500 miles
Marty

Derby, KS

#42 Nov 12, 2006
Judy wrote:
Hi, I have a 94 Buick Park Ave. & my horn didn't work so my mechanic replaced the fuse. Well, in the last twelve hours, it has started "blowing" on it's own while parked in the driveway. I think there might be some sort of a connection between the alarm system & the horn, because the remote would not open the door while the horn was going off. Help me please as I drive 80 miles round trip to school 5 days a week.
Judy, a fuse that keeps blowing means you have a short, that is somewhere between the fuseblock and the horn (or other components on the same circuit) you have a place where the 12 volts goes directly to ground. It could be any failed component in circuit, or it could be wires chafing against the metal body. Take this to a pro, you could spend a lot of time and money trying to find the problem. And it could get worse, even dangerous!
Marty

Derby, KS

#43 Nov 12, 2006
Nelson wrote:
My 96 Park Avenue "Coolant Low" indicator came on a moth or so ago. I checked the coolant and it was fine. Also, no overheatng problem at all. Normal. Now the heater suddenly stopped putting out warm air even though the fan blows like always. Anyone else ever experience this?
It sounds to me like the coolant really is low. When you checked it, I'm guessing that you looked only at the plastic coolant resevoir. The real test is when the engine is cool, open up the radiator cap. BTW, the coolant low sensor is in the radiator, not the plastic resevoir. Very low coolant means there's not enough to circulate around the heater circuit, thus the loss of heat.
While you're troubleshooting this, you might also ask yourself how the coolant got this low. Such a dramatic loss of fluid is not normal. The tubing to the plastic resevoir could be blocked, thus hindering the radiator's ability to "suck" fluid in as needed. That could also be the fault of the radiator cap, or it's improper installation. If you lost antifreeze on the floor, you'd know it. If it's making it into the engine, and passing through the combustion process, you might not.(white smoke out the exhaust) If it's not the cap, hoses, etc, and you continue to lose fluid, then it's time to go to a pro.
Lola C

Arvin, CA

#44 Nov 12, 2006
Hi! Help! I have a 1991 Buick Park Avenue V6 3.8Liter engine. Recently it is not wanting to go after stopping at a red light or stop sign. It has hestitated then abruptly shifted into gear. Last nite it did it when I slowed for a red light that then turned green so I did not come to a complete stop. When i pressed the gas it reved the engine and hestitated the kicked ito gear. I also tried shifting into overdrive or drive 1 and 2 and even reverse and it didnot want to go for about 5 sec. Please tell me it is not the transmission going out!
Marty

Derby, KS

#45 Nov 14, 2006
Lola C wrote:
Hi! Help! I have a 1991 Buick Park Avenue V6 3.8Liter engine. Recently it is not wanting to go after stopping at a red light or stop sign. It has hestitated then abruptly shifted into gear. Last nite it did it when I slowed for a red light that then turned green so I did not come to a complete stop. When i pressed the gas it reved the engine and hestitated the kicked ito gear. I also tried shifting into overdrive or drive 1 and 2 and even reverse and it didnot want to go for about 5 sec. Please tell me it is not the transmission going out!
Lola,#1, check your transmission fluid level. If it's ok, then #2 Look for obvious vacuum hose connections not properly connected under the hood. If this doesn't work, sorry gal, it's time to go to a transmission specialist. Expect anything from a $200 service to a $2000 rebuild. Good luck!
marvin

Mecca, CA

#46 Nov 15, 2006
I have a 1988 park aveanue, which stutters sometimes violently when going up a hill on the highway. It does not do it all the time.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Buick Discussions

Title Updated Last By Comments
2016 envision 15 hr John 2
News Buick LeSabre: Problems & Solutions (Apr '07) Aug 6 Tony 776
News Chevy Trax crossover eclipses Sonic subcompact car Jun '17 Wimsey 1
Poll Why does canada suck (Jul '08) Jun '17 mystic 47
News US Probes GM Headlight Failures, May Add Vehicl... Jun '17 Time machine 063 1
News China's Buick Velite 5 is a Volt with a nose job Jun '17 Over Priced Cruze 4
Owners of Buick Lucerne (Dec '06) May '17 Damn 60
More from around the web