Buick Park Avenue

There are 20 comments on the Edmunds.com story from Mar 15, 2006, titled Buick Park Avenue. In it, Edmunds.com reports that:

Created by sysop in the Buick Sedans Message Board. Your Host is pat What is this discussion about? Buick Park Avenue, Sedan, Auto News, Opinion, Car Photos, Car Reviews # 305 of 314 Re: Fuel gauge fix ...

Join the discussion below, or Read more at Edmunds.com.

donnie

Hartford, CT

#311 May 12, 2009
Bill wrote:
My wifes 98 park ave has something in the trunk area that sounds like an air compressor coming on all the time, can anyone help.
thats normal its the self adjusting leveling system. it elavates the back off the car to a specific height. you mainly hear it when you first start the car.
sue

Ogden, UT

#312 Jul 22, 2009
my 1999 buick ultra is having problems staying on when it heats up it wants to starts but hasn't have changed sensor and tune-up oil change just about everything what the matter seems like everyone has this problem. is my engine dying. I need to know so that I won't keep putting money into it.
sue

Ogden, UT

#313 Jul 22, 2009
I have changed every sensor in the car. but it still want to quit when it warms up.
cindy

Arlington, TX

#314 Aug 3, 2009
help me i have a 1998 buick park ave lost my key got a new one it will unlock the doors but it will not start
yolanda

Madison, TN

#315 Sep 5, 2009
i have a 92 buick park avenue and when i start it and take my foot off of the pedal the car shuts off could it be my battery is not connected well or corrosion on the battery?
Route66

United States

#316 Sep 24, 2009
Skeeter wrote:
I have a 1999 Park Avenue and I started getting water in the spare tire well. Do I need a new trunk gasget?
Yes, you need a new rubber trunk gasket.
ultra man

Welland, Canada

#317 Oct 18, 2009
transmission filter is plugged. spend the 75-125 dollars to have fluid and filter changed
ultra man

Welland, Canada

#318 Oct 18, 2009
Craig wrote:
<quoted text>Dawn I had the same problem, I would be driving, and it would cut out then would start up after a couple of tries, It got progressivly worse as time went by. the problem was the Computer under the dash board it was an easy fix the trouble was figuring it out. I'm almost positive that is your problem.
Crank sensor is faulty or needs to be cleaned. it is located at back of harmontic balancer
Jessica

Rogers, AR

#319 Nov 11, 2009
I have a 1998 Buick PA and the gas gauge will not work. It is not under the stopper it is just below empty and won't move no matter how much gas is in it. Any suggestions?
Chris

Newton, NC

#320 Dec 2, 2009
I have an 88 Buick Park Avenue 3800 front wheel drive. And I had it in 4 garages now & no one can find the problem. If I don't drive the car for two days on the 3rd. day I have to charge the battery it is being drained by 50% in 2 days sitting. Hav enew altinater, Starter an dthe say the checked everything but still the same thing. SO I really need som ehelp tips what to check & look for.
TIA.
tom

Cleveland, OH

#321 Dec 14, 2009
wak wrote:
I have a 87 park ave electra. I'm havine a problem with the car wanting to shut down while driving at low speeds. Also the check engine light comes on right before doing so. Any ideas of what it may be.
check the mass airflow sensor
ray

Norfolk, VA

#322 Jan 5, 2010
Marty wrote:
<quoted text>
Verne, you're not giving us enough information! It sounds like you're out of gas! If that's not the case, you have to tell us more.
i have the same thing happen it was my mass air flow sensor but a yr later it did the same thing there was oil all in where the mass air is it was oil blow by had to replace engin if no oil may just be sensor they replaced me and been fine sence
Heloman_1976

Newnan, GA

#323 Jan 16, 2010
Marty wrote:
<quoted text>
That's interesting. I know "of" the Dynaride system, but have not worked with it. I didn't know it would come on with the engine off. Anybody else know anything about Dynaride?
I am a long time mechanic currently working on Helicopters. I also, have a 95 Buick I bought last year for a couple hundred dollars it is great shpe, and runs perfect only problem is th e Dyna Ride System. If I park the car for any longer than 24 hours, i can forget cranking it without a jump. I sat with a charger on it one weekend to kep the battery up. Turns out the Dyna ride compressor kept cycleing every hour or so for about 5 minute at a time. I am currently looking into leaks , and possible ruptured struts.
maybe i can help

Champaign, IL

#324 Feb 21, 2010
Charles Whitehair wrote:
We have a 1998 Buick Park Ave. Whenever we have an electrial disconnect, ie, battery changed, etc. The gas gauge turns completely to the opposite side,(bottom) and locks up. This has happened 4 times and we have to take it to a garage for the dash to be taken down and repaired. Has anyone else had this problem and if so what did you do to solve problem.
I have a 1998 park avenue and had the same problem, The battery died and the gas gauge would turn all the way around, anyway the easy quick fix is to take a strong magnet and put it up to the needle and turn the needle back to it's original position. NO taking apart the dash. 10 second fix.
Barbara

Fort Walton Beach, FL

#325 Mar 22, 2010
I have a 1991 Buick Park Ave. Turns over but wont start sometimes. Acts like the fuel pump is bad, then other times it runs just fine. Give it a jump and it runs for a short distance then dies. Battery,alternator all tested fine. Can anyone give any advice?
Bob

Minneapolis, MN

#326 Apr 23, 2010
duane in kansas wrote:
i am having problems with a 89 park avenue ,when warm my car dies after being ran a while .we have changed almost everything ... what is wrong with it ?
duane: when it stalls again throw a pretty cold glass of water on crankshaft position sensor (if it starts) replace sensor.
Freebe bob,
Bob

Minneapolis, MN

#327 Apr 23, 2010
Duane: When Avenue stalls again :Throw a cold glass
of water on crankshaft position sensor:if starts
replace sensor!
Freebe,
bob,
shelly

Halethorpe, MD

#328 May 4, 2010
i got a 93 park vave i will drive,it fills like is going to cut off, some it it cut off, i put it pack in [N] START IT BACK UP, CAN IT BE A VACU HOSE, IF IT IS CAN YOU TELL ME WHERE IT IS, THAT YOU
shelly

Halethorpe, MD

#329 May 4, 2010
hi there i got a 93 park ave, i will be driving my car stop running,i put it back in[N]start it back up when i am driving it fil like it woulds to stop, can it be a vacm hose, there is a new fuelpump, fuelfilter, please help me, if you think it is the hose can you tell me where to look to find it, thank you [MICHELE]
Den

Chester, VA

#330 May 19, 2010
I have a 2000 Park Avenue. After how many miles should I plan to replace the timing chain? Currently I have 148,000.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Buick Discussions

Title Updated Last By Comments
Owners of Buick Lucerne (Dec '06) 21 hr Toby 51
News Buick LeSabre: Problems & Solutions (Apr '07) Apr 29 Crystal 721
my build 2006 rainier, I turned the knob ,and t... Apr 13 mindy 1
News Eddie Wiggins car dealership closes in Warner R... (Jan '09) Mar '15 Kyle 10
Poll Why does canada suck (Jul '08) Mar '15 RV Guy 43
News GM Extends Warranty on Some Front Wheel Bearings (Nov '06) Mar '15 eric 104
News Ask the Auto Doctor (Dec '07) Jan '15 japple 13
More from around the web