Overheating
Chris Cortez

Humble, TX

#1 Apr 10, 2006
My 2003 Century heats up in traffic with the air off. Oddly, turning the air on, actually brings the temp down. One mechanic surmised bad fans. Fans checked out okay. Another plugged leaks in the intake manifold (expensive!). Didn't fix it. Since the car doesn't actually overheat, but simply runs hot, the mechanics are sceptical, but I swear it happens!
This has been going on for about 6 months, and I'm going insane. I think it is a sensor, which is supposed to turn the fans on, that has an intermittent problem. When I turn on the air, I force them on. When I bring it in to the dealer, it happens to be working. Seems to fail after about 30 minutes of operation. The temp needle goes past the midway point. Any ideas? Thanks.
G Foster

Wayne, MI

#2 Jun 6, 2006
My 98 Century is running hot, but not quite overheating. It got close to redlining. It happens when the weather is hot and the sun is shining and in city traffic or on the freeway when I am running the air conditioning. Any suggestions? I replaced the water pump and put a new thermostat in last fall. I am running GM coolant recommended for the car. Thanks.
foxtail

Burlington, Canada

#3 Aug 15, 2006
One thing you might want to check is too see if the plugs are the right ones for the car. Some plugs are speced to run hotter. Maybe check to see if you can get the fans to come on earlier.
Aimee

Winter Haven, FL

#4 Aug 29, 2006
what do u mean by plugs??
foxtail wrote:
One thing you might want to check is too see if the plugs are the right ones for the car. Some plugs are speced to run hotter. Maybe check to see if you can get the fans to come on earlier.
Aimee

Winter Haven, FL

#5 Aug 29, 2006
my car is a 92 buick century special edition and it over heats if i sit at a red light to long or if i am stuck in traffic even if i have the AC on!! i think my fans might not be working either
Fritz M Plattner

United States

#6 Dec 13, 2006
As easy to realize, with the only Buick in a wide area of East Africa, I have to fight so many problems
but..........
The must sturbon one, which had stranded my Buick totally is the fact, that after driving some 4 km, without any reason, the engine stops and can not be started until the engin cools down. Then I can run a other 1 km, then the same. All mechanics here arround have failed.
I should crack down the Buick, but I rather try to find some advise how to overcome this problem and what can be done. Is there a heat sensor who cut off the ignition or the injection. What has the temp to do in it. Unfortunate I have failed to get the technical documentation from Canada.
Checked is:
- Fuelpump running
- Backflow from engin ok
- Thermostate removed (outlet hot from engine)
- Pressure to injection ok
- Acceleration as long before 4 km very good
Any recommondation for this obvious difficult case?
[email protected] g
[email protected]
Gary

Bringhurst, IN

#7 Dec 18, 2007
I have a 93 Buick Century. It ran fine until winter. It overheated and now i cant seem to put enough Anti freeze in it. Do I have a leak or is it something more complicated. This seems to be a common problem with Buicks. please Help
tony

Ocala, FL

#8 Feb 25, 2012
i have a 98 buick century and at one point the fan relay went out so i replaced it and no overheating problems for about a month an now all of a sudden its overheating bad and i can hear water hissing like its leaking somewhere around the thermostat not a big leak or alot of water.....once it reaches one knotch passed normal i come to a stop and the car stalls....it does this after about 5mins of driving....could this be my thermostat?
Ben

Sanford, NC

#9 Jul 29, 2012
the temp sensors in buicks are 210 degrees which is normal you can put a temp sensor in with a lower temp on it might wreck fuel economy though.if your car sticks around half or a little higher its normal
Christie

Charlotte, NC

#10 Sunday Jan 8
Just recently my buick will try to run hot it will go over the middle normal gauge to the next then go back to normal after five minutes or more and it keep repeating

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Buick Century Discussions

Title Updated Last By Comments
windshield wipers on 2002 buick century (Oct '07) Dec 21 Arthur 34
A serious stalling problem... (Jul '06) Dec '16 Joseph Garza 199
92 regal stalling and dying while driving. Dec '16 nattie_catt 1
A permanent fix for the multifunction switch pr... (Jun '11) Nov '16 Krystin 17
2000 century anti lock brake light stays on (Nov '06) Sep '16 cube 23
'92 Buick Lesabre cuts out while driving... hav... (Jul '07) Sep '16 Greg 23
I have a 1994 Buick century that will start but... Sep '16 Tim 3
More from around the web