GMC Acadia Problems and Repairs

May 22, 2007 | Posted by: roboblogger | Full story: Edmunds.com

Replying to: ppalonsky FWIW, the shifting issue has a TSB issued and a dealer can fix it, and the gas gauge being off is going to require a software update that is in development. via Edmunds.com

Comments
181 - 200 of 397 Comments Last updated 20 hrs ago
Disappointed Outlook ownr

Odessa, FL

#182 Apr 14, 2012
I have also experienced the loss of power steering during heavy rains, but I would also lose power to the vehicle. This began the first year we owned the 2008 Saturn Outlook while living in Abilene, Texas. I was told two different visits by service managers at the GM dealership there that they have never heard of that happening. This was a big concern as I drive two children around (a baby and 5 yr old at that time) at we were moving to Tampa to live and I knew how the rains were there. After taking our Outlook in many, many times in Tampa, I asked if they knew what caused the power-steering loss and I was told about the design defect and that there was "NOTHING" that could be done to fix it. Unbelieveable the one time we chose to buy American over Japanese, and we get slapped in the face...and we went with GM because they had a special sales program for military members (my husband has served in the Air Force for 24 years). We love our country...just not GM's vehicles!!
mag808 wrote:
We own a 2007 Acadia and had had relatively few problems with it until last Sunday when I experience the loss of power steering during a rainstorm. The dealer told us that the failure of a "trim piece" allowed water to infiltrate the power steering unit and caused the loss of power. Although we purchased an extended warranty, we were told that the warranty did not cover repair of the "trim" problem. It turns out that it's not a trim problem; it's a design defect. The cowling inside the wheel-well isn't long enough to protect the power steering unit from water puddles. The fix is to attach an extension to the front wheel-wells so that the unit is protected. For this we were charged $400!!! Since it is apparent that GM is well aware of the problem, we will be following up with GMC and with the NHTSA.
Greg

Northford, CT

#183 Apr 20, 2012
I own a 2009 Acadia and the other day while driving the engine stalled out. I had it towed to a local dealership and they told me the engine was gone. The oil was like mud. I had gone about 8k without an oil change. Over I know but enough to ruin the engine? I have talked to several other mechanics since yesterday and they can't believe it happened. Of course, because I didn't perform the maintenance on time, I'm out of luck. I have owned Fords,Nissans,Lincolns,Acuras and a Subaru and have missed maintenance before with no damage whatsoever. I will never,ever own another GMC product. Its the most horrible car I've ever owned.
john

Westminster, CA

#184 Apr 22, 2012
bill wrote:
I have a 2009 acadia. It has a humming noise in the engine. It has been in 4 times for this. They put a new program chip in for this it did not solve it. I have to have my radio on so I can not hear it. Now the engineers are suspose to be looking into this. I may look into the lemon law
I have an 08 acadia with the same noise issues. Did you ever get it fixed?
Antoon Eyer

Winnipeg, Canada

#185 Apr 24, 2012
My 2009 Acadia's back hatch door not opening. I left my doors open, opened the hatch and then closed it. It will not open again. I have tried to start my vehicle put in in reverse and drive and then parked it. Still won't open. What the %$^^$ is wrong?
BUDDY FORD

Longview, TX

#186 Apr 25, 2012
on a 2008 gmc acadia,every time i raise it up to change the oil and rotate the tires,when i let it down and take it off my lift it has a bouncing feel to it for about 3 weeks and usually smoothes out and back to normal- has anyone else had this problem ?
Frank Miklos

Ambridge, PA

#187 Jun 15, 2012
My 2009 Acadia started to have a transmission slip... Looks like this is a problem that is common with the Acadia... Years ago I had a 1996 van that the tranny started to shutter... Is this a similar problem ... Can I use the same treatment to solve this problem... That product was "Dr Tranny Shutter Stop" I would have to do a treatment about every 10K. Which worked well. It was amazing you would put this little tube of liquid into the tranny. and within 5 miles the problem went away... Will this stuff hurt the Acadia transmission?
caeanis

Denver, CO

#188 Jun 22, 2012
No Faith wrote:
Iou have expereinced the same problems, AC problems, Stability track, skidding in puddles, etc...07 with less than 30000 miles and car is in shop now because of crank shaft, cylinder bad. They should have a recall with the engine as it is bad, but I contacted GM and have demanded answers. If your car is experincing any of these issues, warranty or not they are obligated to fix it and compensate you for any inconvenience. Think there should be a class action lawsuit against GM for this. I was informed GM knows about these issues for model years 07-09, yet refuse to do a recall and desling with them on a case by case basis. This is what we get for being loyal to GM --totally screwed!
I just made my second payment on the car and this morning transmission started acting up. You mentioned that they are obligated to fix these issues, is that your opinion or the attitude GM expressed when you talked them. Understand I'm not being sarcastic, I am wanting to know if I contact them can I expect that they'll make it right? Even without a warranty? Do you have advice on how to approach it so that I can at least get a fair shake?
jeremy

Bellefontaine, OH

#189 Jun 25, 2012
Chris M wrote:
I have been having engine issues with my '09 SLT. The engine randomly hesitates and sputters at highway speeds. I have taken to the dealer three times and have had an injector flush, replacement of all three (primary and secondary) timing chains and nothing on the third try as the dealer has not been able to figure out. The mechanics drove the vehicle as I requested to try and duplicate the issue since the engine light won't stay on when the car starts a buckin'. Looking to bring back for the 4th time. Also the rear hatch locking mechanism that holds the gate open just broke. Extended warranty to expire soon. Really like the vehicle, just want the issues cleared up so I can drive without feeling like a possible break down may occur at any time in a car that is just over two years old.
Change your spark plugs .... I have an 09 acadia sl model. it is actually not that bad to change them once you get the manifold off! it took my grandpa and i 2 1/2 hours to tear apart, replace plugs, and put togther ! i am have issue with extremely tight steering at low speeds
simbimbo

Natick, MA

#190 Jul 25, 2012
So far I have had almost all of the issues listed on this forum

Sunroof recall. Drop headliner and fix drain hoses
Transmission shifting issues. Reprogram TCMA
Stretched timing chains. Drop engine and replace
Headlight burnout. Replace connectors
Squeaky Drivers seat, seat moves. Replace seat mounting rails.
Weird A/C control issues. Hard to control temperature. Reprogram control modules
Steering noise. Replace steering hoses
A/C makes hissing noise. Replace A/C hoses
Brake pedal noise. Replace brake fluid
Wheel bearing failure. Replace hub assembly
Erratic shifting, no reverse. Waveplate failure. Rebuild transmission.

The latest is the transmission failure, let me elaborate.
simbimbo

Natick, MA

#191 Jul 25, 2012
Day 1::

Well, I'm at the dealership. We took it for a ride with the tech.. While on a test drive the car experienced a very hard shift into 3rd gear. The tech took it into the bay and topped off the transmission fluid, took it for a ride and said it seemed better..

I left the dealership and got on the on ramp to the highway and the car revved really high on a downhill ramp then banged into gear. I thought that was strange, so I continued on the highway. I then noticed some very erratic shifting and some more banging into gears, so I got off the highway. On the back roads I could hear a scraping noise in second gear and more hard shifting. I immediately called the dealership and told them I was heading right back, but may not make it.

When I arrived I grabbed the tech and we started to go for a ride, but when he put it into reverse, it began bucking and grinding. We didn't even try to take the test ride because it was so bad.

I'm sitting I the waiting room trying to figure out how I'm going to get a car that can tow my popup for our weekend tubing trip.

P.S. this was going to be the first time I towed with this car, it has the tow package, I thought maybe it would be immune to the 3,5,R waveplate failure, but I guess I was wrong.
simbimbo

Natick, MA

#192 Jul 25, 2012
Day 2::

I'm in a loaner Acadia now, the only problem is, there's no trailer hitch.
I'm supposed to leave for a weekend getaway with the family tomorrow at 2 PM, with pop-up trailer in tow. If I don't get a call back from the GM representative with a solution (hopefully a car with a trailer hitch). I'm going to have to cancel our weekend camping trip.

I would really hope a GM representative from this forum would contact me, to help me figure this out.

Day 5:

I just spoke to the dealer and they are going to rebuild the transmission this week. I'm really beginning to worry about this car. I hope I didn't make a mistake when I purchased it.
simbimbo

Natick, MA

#193 Jul 25, 2012
Day 7::

After reading more posts about the transmission failures and associated failed repair/rebuild attempts at various dealerships on this forum and on Edmunds forum, I began to worry that this repair would be the beginning of a long, drawn-out problem, so I called GM customer service to see if anyone there could help me. I was in contact with a regional specialist named Matt who told me he was going to contact the dealership to find out what was going on then get back to me; that was yesterday around 2pm. After 2 calls placed into him; I heard from him today, but there seems to be a huge disconnect between what he and I are discussing and what the dealer is doing, let me explain. Matt and I are discussing a new transmission for the car, but the dealer has no information on that from Matt, so whenever I talk to Matt, he tells me he is working on a new transmission, but when I talk to the dealer they keep telling me the rebuild is going great and I should have the car back soon… I'm really getting frustrated.

Skip to yesterday afternoon....

I received a call from Matt who was sorry to tell me that the GM rep responsible for my area worked with the dealer, and that the decision was made to rebuild the transmission instead of installing a new transmission because "It was in GM's best interest". I find this to be insulting.. with all of the issues I have had, I have been without this car for just under 3 weeks out of the past 6 months.

Skip to this morning..

The dealership called me to tell me the rebuild was going well, and the transmission was going into the car today and they were going to test it extensively before I would be able to pick it up. I told 3 service writers at the dealership that I hope they take the time to do things right because this car was going on a 500 mile trip this weekend including a run to the top of Mount Washington as part of my companies "Summer Outing". I told them unlike the other repairs they have made, on this one there is no option to "get it right the second time".

I just would like to say, although the GM reps on this forum and on the phone are very polite, and the dealership is also very nice, I feel as if all of the posturing and attempts at helping me with this issue, from the initial failure, the camping weekend, new transmission, etc.. resulted in, well, nothing. I have received plenty of lip service, and promises to "look into it", but the fact is, I had to borrow a friends car for the camping weekend, and I'm still getting a dealer rebuilt transmission, so it was all for nothing. I'm very underwhelmed..

I can only hope that the transmission is rebuilt correctly, and doesn't fail again.
cari

Lake Charles, LA

#194 Aug 1, 2012
wanted to know if you ever determined why this happened... my 2008 saturn outlook just did this two days in a row at 34k miles and the dealer is giving me the run around as to why it happened.
MBD wrote:
"Stabilitrack off" came on and is followed shortly after by "Service Braking System" message. I used the parking brake once the other day and released it before driving. A little later was driving out of my garage and the door would not close so I braked before leaving my driveway until it closed. During this time the "Stabilitrack off" message came on, lit up the icon on the dashboard along with the brake icon. Eventually having the car off for awhile it reset. Then this morning, it all came back on (two days later) while sitting at a stop light. I have just over 69K miles on it. I'm set for a dealership review tomorrow along with a slightly overdue oil change. I think this car is a piece of garbage. All our repairs have been expensive. We even lost our antenna just using a drive in car wash!!!! I have not attempted to repair that...
poobear

Wixom, MI

#195 Aug 10, 2012
I have a 2009 acadia awd and about a month ago my wife was leaving for work and it wouldnt start so i jumped it and fired right up she got to work and went into work taking the keys with her keep in mind.And came back out to get something out of it and noticed that it was still running. to it back to dealer and they said they couldn't find anything wrong with it so they reprogrammed it and away we went. 2 weeks later get up on a saturday morning to go the store come out of store and it wouldnt start after a hour of trying to jump start it with my friends brand new diesel it wouldnt do anything so after another hour playing with it we unplugged the computer under the hood and plugged it back in the car fired right you so we go to leave and get on the highway and as soon as i give it alot of gas it goes into limp mode. so now i have to drive 10 miles to the closest auto parts store at a blistering 15 MPH no a/c and its 90+ degrees outside get it there get it all cleared and away we went. So then we get ready to leave to go to dinner that evening so i started it just to be curious if it would start and it did but wouldnt shut off with the keys out of the ignition again. So back to the dealer it goes now they say its the drain tubes for the sunroof causing this to happen. But if that was the case my floors would be wet and it would have happened when they washed before we went and picked it up the first time or the 3 other times we washed it in between accurances. If anyone has had the same kind of issues please let me know
Bill

Youngstown, OH

#196 Aug 11, 2012
Owner of a 2008 SLT. Many of the previous problems,I have had. Steering, CVU joint, leaking boot, steering u-joint shaft, moon roof leaked in to the fuse box and car keep running. Head light bulbs.(Lights are fog up inside now)
Today tranny stated to slip in 3rd gear. The steering wheel rub's on the air bag when you turn the steering wheel. Power steering pump is whinning. 55,600, what will the next 50,000 bring?
Corinna

Orange, TX

#197 Aug 23, 2012
Frustrated wrote:
I have a 2008 Acadia. The service air bag light has been on since November. I took it to have it fixed in November because I was going out of town. After I picked it up I drove about 200 miles and the light came on again. I took it back to the dealership and after tearing in to the dash they still couldn't fix the issue. Several months later I am still driving with the Service air bag light. Is this a safety issue? No one can seem to fix it and no one can tell me. Does anyone else have this problem. I too have had issues with the starter and the altenator.
..........i have the same problem idk what it is but my stabilitrack light stays on and the traction control..so i have those three on and i have had it 2 months
Dennis Williams

South Lyon, MI

#198 Aug 24, 2012
My wife was in an accident with our 09 Acadia. With the whole front clip wasted and both frame rails bent at a speed of 40 to 45 miles an hour, the airbag did not deploy. The seat belt broke loose from the ceiling mount though. Now GM is dragging their heels on the readout of the computer. Their independent contractor came late to read the info, and said I would here in 5 days from GM about the readout. Called and was told it was still under investagation. Anyone else had any airbag problems? I don't want a vehicle with 15,000 dollars worth of damage back. Quite a loss of value when Carfax is checked.
X gmc fan

Tijuana, Mexico

#199 Sep 6, 2012
PROMBLEMS WITH TRANSMISSION AT 48,000 MILES ON MY 2007 ACADIA SLT, VERY EXPENSIVE CAR TO BE WITH THIS TYPE OF PROBLEMS,HAS ROOF LEAKS, LUCKILY GOT THEM TO REPLACE THE WHOLE INSIDE OF THE ROOF BECAUSE IT GOT DAMAGED, AND WAS STILL UNDER WARRANTY..., PLATE UNDER THE CAR GETS LOOSE AND YOU CAN HEAR A CLINGING NOISE, POWER STEERING SOUNDS LIKE IT LACKS OIL... ETC ETC ETC,,,, NO MORE GMC FOE ME
Ken

Oakville, Canada

#200 Sep 21, 2012
Also frustrated wrote:
My 2008 Acadia SLT, AWD leaks water from the door frame airbags and now from the sun visor whenever it rains. The first time this happened, the fuse box got wet and the car died completely. It was fixed 1 month ago and the dealership said it was because the sun roof drains got clogged. Now today it has started leaking again and it also started leaking from the ceiling light between the 2nd and 3rd row seats. When I tried to turn off the car, it wouldn't turn off, even with the key removed. It took many tries to get the car to turn off, finally I accomplished it by putting the car in reverse, neutral, drive and then back to park. It goes back to the dealer tomorrow.
I had the same problem and thought it was the sun roof, but one day in the wind I heard a hissing sound and thought my driver side window was open slighly. I looked at the front windshield and at the top corner it wasn't glued in tight and I could actually push it open from inside. Thats where the water was coming in and going down inside the post to the airbag outlet and through the visor arm. I got the window taken off and reapplied by a window specialist. Problem solved......for me.
alaa

Saudi Arabia

#201 Sep 24, 2012
good

Tell me when this thread is updated: (Registration is not required)

Add to my Tracker Send me an email

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

BMW Discussions

Title Updated Last By Comments
bmw parts south africa - bmw spares (May '10) Aug 26 kleo 214
BMW X3 facelift launched in Malaysia, India lau... Aug 17 PAK JUMADI 1
BMW Fix for E46 M3 SMG problem (Jul '07) Aug 15 wok 105
F25 BMW X3 LCI debuts in Malaysia - two CKD var... Aug 15 Crush Em 2013 1
2008 Mercedes-Benz C300 (Sep '07) Aug 12 Gary 72
BMW warns on mass fraudulent emails under the n... (May '07) Jul '14 roshani 1,143
Is This How General Motors Will Fix Cadillac? Jul '14 rasmaxwell 1

Buy a New Car


Zipcode:
•••
Enter and win $5000
•••

BMW People Search

Addresses and phone numbers for FREE

•••