2003 K1200LT Stereo problem

2003 K1200LT Stereo problem

Posted in the BMW K1200lt Forum

Terry

Collingwood, Canada

#1 Jun 22, 2011
Looking for some troubleshooting advice for my 2003 K1200LT. When first taking it out this season, the stereo stopped working, but the display was still lit. I unplugged the battery and it reset itself and all was well....for about a week.....now only the front right speakers work....Anyone have same issue?
Phil cawley

Ireland

#2 Jun 23, 2011
Terry wrote:
Looking for some troubleshooting advice for my 2003 K1200LT. When first taking it out this season, the stereo stopped working, but the display was still lit. I unplugged the battery and it reset itself and all was well....for about a week.....now only the front right speakers work....Anyone have same issue?
I had the same issue on my 02 and the stereo was replaced under warranty. The same problem on my 05. No satisfaction from main dealer and no explanation as to the problem. I personally think it's a wiring issue. I can't afford a replacement and labour cost to strip the panels for an examination come out the same for replacement unit! I'm now getting used to listening to clright side only!
Terry

Collingwood, Canada

#3 Jun 23, 2011
thanks for the quick response....guess I will have to tuff it out as well.....this is a big disappointment since I bought a BMW for big $$$ to have a dependable machine.....
rampsup2

Silver Spring, MD

#4 Oct 7, 2011
Glad im not the only one with the same issue. I have an 05 model and it started acting up this year. My front speakers come on then cut out. Its common in all modes of the sound system, radio(am fm) and cd player. Plan on taking it apart and finding the problem myself and when I find the answer will post results
FZRDES

Raleigh, NC

#5 Mar 23, 2012
I have an '03 and first the radio wouldn't receive stations, then the CD player stopped. Found out that a mouse got up into the dash over the winter and chewed some wires which were shorting out. There was also a bad connection on one of the pins in the round connector due to corrosion. Taped the wires and cleaned the terminals and used some electrical grease on them. Had to replace the short antennae wire under the dash. All working now. My suggestion is to eliminate all connectivity issues before looking for a new unit.
ben wilmington nc

Wilmington, NC

#6 May 17, 2012
I have had 2 BMW LT 1200, both had radio problems. Warranty out. Cost to replace without installation $1,000+/-. Nice bike but crappy sound system. Help, cannot find a used replacement.
LTinnin

Aurora, CO

#7 Oct 5, 2012
I recently bought a 1999 K1200LT after 26 years of Goldwings. I have found one issue with the radio I cant make sense of. I have a helmet with speakers and a mic. The real concern comes in hearing the radio. I cant seem to stop the mic from collecting road noice and wind and feeding it right back into the speakers. Also it seems you cant cut out the speaker on the bike when you're listening thru the helmet. If you use the "volunme" control under the cover, you turn up the sensitivity of the mic at the same time.
How do I cut out the mic, and yet control the radio volume into helmet speakers ? And can I cut out the bike speakers while using the helmet ?
JOHN DURHAM ENGLAND

Stockton-on-tees, UK

#8 May 26, 2013
SITE ON EBAY UK WILL FIX UNITS FOR £150. COMPONANTS IN THESE UNITS ARE REPLACED AND UPGRADED. HAVE SEARCHED SITES FOR UNIT REMOVAL ADVICE BUT NO LUCK!!!!!!!!!!
DANNY HUDGINS

Elizabethtown, KY

#9 Jul 1, 2013
I HAVE A K1200LT 2005 RIGHT FRONT SPEAKER QUIT THEN THE REAR SPEAKERS QUIT TO,
gary welsh

Lancaster, PA

#10 Mar 22, 2014
2001 klt radio road thru very heavy rain 800 miles when turned bike off radio and other components stayed on disconnected battery next day radio did not work but late in the day it worked on left turns at the end of the day radio did turn off now on light is on but nothing turns on any help control or radio trouble shooting found that ign. switch was problem with not shutting radio and components had to replace swicch bad connection in it thanks for any help I am a master truck tech and able to trouble shoot if have a direction to go
Prm

West Jordan, UT

#11 Jun 28, 2014
Had '05 lt. Same issue with radio. Under warranty replaced 4 radios in 2 years
Bmw corp would not own up to problem. Could not believe it.
Looked into lemon law, but Michigan does not have lemon law for bikes.
Mechanic at dealer said he had dozens in back room waiting for BMW to cover him.
Waited till warranty was up, traded in for 1600gtl.
No poroblem with gtl.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

BMW K1200lt Discussions

Title Updated Last By Comments
1200lt 2005 Jul 14 Hondo333 1
Intercom removal May '16 Chiller 1
gps willnot turn on Apr '16 Daniel 1
Speedometer sensor hole? PLEASE HELP (Aug '15) Aug '15 Darkteivel 1
2003 k1200lt (Jan '14) Sep '14 Mike Regan 2
K1200 LT 1999 Rear break problem (Aug '14) Sep '14 MikeRegan08 2
Reliability (Jun '14) Jun '14 Scott 1
More from around the web