EPC and ESP Problems
First Prev
of 4
Next Last
stefan

UK

#1 Feb 23, 2007
Please can anybody help ?

The EPC and ESP lights on my 02 Petrol A4 2.0L have come on and won't reset.

This has happened a few times before but has always reset if the ignition is switched off and back on again.

When these lights come on the engine goes in to a kind of 'safe mode' whereby it will run but only with limited power.

I've had it plugged in to a diagnostic machine at the local garage and the fault code says something about the 'Throttle position sensor'.

Can anybody shed any light on this before i start pulling it to bits in the morning ?
andre

India

#2 May 31, 2007
Hi there.
My S6 started doing the same today. Did you get this resolved?
What was the problem and what did it cost to fix

Cheers
Andre
andre

India

#3 May 31, 2007
stefan wrote:
Please can anybody help ?
The EPC and ESP lights on my 02 Petrol A4 2.0L have come on and won't reset.
This has happened a few times before but has always reset if the ignition is switched off and back on again.
When these lights come on the engine goes in to a kind of 'safe mode' whereby it will run but only with limited power.
I've had it plugged in to a diagnostic machine at the local garage and the fault code says something about the 'Throttle position sensor'.
Can anybody shed any light on this before i start pulling it to bits in the morning ?
Hi there.
My S6 started doing the same today. Did you get this resolved?
What was the problem and what did it cost to fix

Cheers
Andre
Lloyd

Middletown, NJ

#4 May 31, 2007
The check engine lite of my 06 A4 Avant recently had a problem. The dealer service folks told me that they reprogrammed it and it did not lite up again for a thousand or so miles. It is back on again with no apparent cause and I am taking it back to the dealer again. Anyone else having this problem?

“Why the Hell NOT!!!”

Since: Jun 07

Bronx, NY

#5 Jun 26, 2007
EPC (Electronic Power Control) is your throttle valve, and your ESP (Electronic Stability Program) would come on because anytime you lose traction your ecm cuts back power by limiting your throttle by closing your throttle valve. You need to go to a certified dealer so that they can check the wiring between your throttle valve and the ECM. A garage cant do this because they don't know what wires are power and what are signal. If all wires and signals check out, you need a new throttle valve. If the wires don't check out, they need to find out if the wires are shorted or is the ECM giving incorrect information.

Judged:

22

21

1

Reply »
Report Abuse Judge it!
Katwoman

AOL

#6 Sep 10, 2007
My EPC light is on, along w/the check engine. After going to 3 different mechanics (my A4 is 10 months out of warranty) I was finally told it is the 'crank sensor'(what teddys13 says makes sense to me, b/c the car has shut itself off/stalled when I turn a corner on an incline and it feels as though I'm out of gas, ie the throttle valve closed) Plan to hit Audi the end of this week, any words on a similar problem would be appreciated!
fozzie

Gloucester, UK

#7 Mar 27, 2008
my mrs mom had an auldi tt 1.8 quatro. now i a fuly quilifed mechanic but cnt fiqure it out. she say s she gets to 80mph n car cuts off n caries on agen seconds lata but only at 80 but only since she had her esp changed
adam

Nicosia, Cyprus

#8 Apr 13, 2008
Katwoman wrote:
My EPC light is on, along w/the check engine. After going to 3 different mechanics (my A4 is 10 months out of warranty) I was finally told it is the 'crank sensor'(what teddys13 says makes sense to me, b/c the car has shut itself off/stalled when I turn a corner on an incline and it feels as though I'm out of gas, ie the throttle valve closed) Plan to hit Audi the end of this week, any words on a similar problem would be appreciated!
did you solve the problem i have a simular one on the a3 2002
Yeah right

London, UK

#9 Sep 2, 2008
Quote...>>You need to go to a certified dealer so that they can check the wiring between your throttle valve and the ECM. A garage cant do this because they don't know what wires are power and what are signal.End Quote<<
What a load of rubbish.... a lot of "garages" know more than a lot of dealers -- because they have "mechanics" not just "fitters"!.... no disrespect to dealer employees -- but it happens !
YR
M Brown

United States

#10 Oct 1, 2008
I have a 2008 Audi A4 2.0. The EPC and ESP lights come on, I then have to shut off the car and restart and usually they go off. If I drive without doing this procedure the car shift terribly and has low power espeically at 60 MPH.The dealer has had it 3 times with no luck. AUDI you need to look into this and solve this annoying problem!!
stefan wrote:
Please can anybody help ?
The EPC and ESP lights on my 02 Petrol A4 2.0L have come on and won't reset.
This has happened a few times before but has always reset if the ignition is switched off and back on again.
When these lights come on the engine goes in to a kind of 'safe mode' whereby it will run but only with limited power.
I've had it plugged in to a diagnostic machine at the local garage and the fault code says something about the 'Throttle position sensor'.
Can anybody shed any light on this before i start pulling it to bits in the morning ?
willie

Kilkenny, Ireland

#11 Feb 7, 2009
A4 02 2ooo Audi pertol sometimes starts to surge and if switched off can be difficult to restart as if it has no fuel
willie

Kilkenny, Ireland

#12 Feb 22, 2009
02 Audi petrol, sometimes the revs surge and then return to normal, sometimes is difficult to start if hot, EPC light on but can be reset without indicating where the fault is ??
audi johns creek

Statesboro, GA

#13 Mar 10, 2009
willie wrote:
A4 02 2ooo Audi pertol sometimes starts to surge and if switched off can be difficult to restart as if it has no fuel
same year same problem how did you fix it
willie

Wexford, Ireland

#14 Mar 13, 2009
still not resolved
Dave

United States

#15 Jul 17, 2009
My diff is locked and the ESP won't work. I also have a code reading "rev limiter" or something like that. Done a bunch of stuff and nothing works. So can someone tell me what to expect from the dealer. Here in Utah the dealers are unfortunately notorious, they tried to charge my brother 7500 for a valve job and another shop did it for 1800. Any additional advice would be appreciated. Thx Teddy13
Dave
Ben Dover

Hawley, PA

#16 Aug 18, 2009
I bought a 2001 A4 with 81k miles. After driving 800 miles or so the EPC light came on and the car was basically cut to idle. Turned it off restarted, light went off, problem was gone. This has happened two more times in the past 200 miles. The code displayed is 1542-throttle actuation potentiometer implausible signal- Any ideas what the problem is likely to be? I hear people spend lots of time & money on this issue and it often returns.
jason monem

UK

#17 Oct 8, 2009
iv had the same problem with my 2001 a4 1.8 turbo noone seem to know how to resolve it? many people have spent lots of time and money replacing diffrent parts and the problem doesny seem to go away can anyone help me??????????
Rock

Houston, TX

#18 Nov 25, 2009
I have the ESP light continuously on now on my USA 2003 A4 3.0.

At first it would come on and the off after a few miles but now its on all the time.

When its on it has that "safe mode" kind of feel,
where the transmission shifting and changing from park to reverse to drive is rough.

Luckly the performance is still there and once warm and at speed it seems perfectly normal.

This is not anything to do with a low fluid level is it?

Like dave above, looking for good information
so I know whats going on before the mechanic says $7500.

Cheers.
jason monem

UK

#19 Nov 26, 2009
i had same problem with esp light on my a4 for months.
i replaced the crankshaft position sensor witch cost 20 and took about half an hour.
it completly fixed the problem.
shows u how to do it on a4 mods under engine speed sensor.
Rock

Houston, TX

#20 Nov 27, 2009
jason monem wrote:
i had same problem with esp light on my a4 for months.
i replaced the crankshaft position sensor witch cost 20 and took about half an hour.
it completly fixed the problem.
shows u how to do it on a4 mods under engine speed sensor.
Thanks Jason,
Wow, seems simple and straght forward.
Im a member on Audi Forums but no mention to ESP.
I'll check now with engine spped sensor.
Cheers!

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 4
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Audi A4 Discussions

Title Updated Last By Comments
Audi A4 2001 dashboard warning lights (Feb '10) Oct '17 Poyotte 6
Audi 2000 A4 quatro 1.8 Jul '17 Lee-Duran 1
fan comes on when car if off (Feb '17) Feb '17 ralph 1
Oil problems in 2007 Audi A4's with 2T engines. (Feb '09) Feb '17 lets 300
News What Secrets Are Behind Tesla's Model 3? Bloomb... (Mar '16) Aug '16 dutko2385 2
A4 Owners Manual Download (Feb '06) May '16 Blessed 291
How to replace brakelights on a 06 audi A4 ? (May '16) May '16 nokedly2 1
More from around the web